BGP-EVPN at SLX-OS

We using eBGP for creating BGP-EVPN 3-Stage fabric with SLX-OS. Noted that Interface, IP address, Speed Interface also AS Number BGP can be adjusted.

Global MTU Config
================
mtu 9216
ipv6 mtu 9100
ip mtu 9100

Config Interface P2P
#Leaf:
Interface Ethernet 0/1
speed 1000
ip address 1.1.1.1/30
no shutdown
————————-
#Spine:
Interface Ethernet 0/1
speed 1000
ip address 1.1.1.2/30
no shutdown

Loopback Iface and Router-ID
===================
#Leaf:
interface Loopback 1
ip address 192.168.0.2/32
no shutdown
ip router-id 192.168.0.2
———————————–
#Spine:
interface Loopback 1
ip address 192.168.0.1/32
no shutdown
ip router-id 192.168.0.1

eBGP Config
========
#Leaf:
router bgp
local-as 65551
fast-external-fallover
bfd interval 300 min-rx 300 multiplier 3
capability as4-enable
neighbor 1.1.1.1 remote-as 65550
neighbor 1.1.1.1 soft-reconfiguration inbound
address-family ipv4 unicast
network 192.168.0.2/32
maximum-paths 8
graceful-restart
———————————————————–
#Spine:
router bgp
local-as 65550
fast-external-fallover
bfd interval 300 min-rx 300 multiplier 3
capability as4-enable
neighbor 1.1.1.2 remote-as 65551
neighbor 1.1.1.2 soft-reconfiguration inbound
address-family ipv4 unicast
network 192.168.0.1/32
maximum-paths 8
graceful-restart

EVPN Tunnel Overlay Gateway Config
========================
overlay-gateway test
type layer2-extension
ip interface Loopback 1
map vni auto
activate

BGP Overlay Config
============
#Leaf:
router bgp
address-family l2vpn evpn
graceful-restart
neighbor 1.1.1.1 encapsulation vxlan
neighbor 1.1.1.1 next-hop-unchanged
neighbor 1.1.1.1 activate
———————————————-
#Spine:
router bgp
address-family l2vpn evpn
graceful-restart
retain route-target all
neighbor 1.1.1.2 encapsulation vxlan
neighbor 1.1.1.2 next-hop-unchanged
neighbor 1.1.1.2 activate

VNI extension Overlay config
==============
evpn default
route-target both auto ignore-as
rd auto

L2VNI Configuration
=============
#at each end tunnel VNI device (Leaf)
vlan 5
description L2 Tenant Vlan
router-interface ve 5
interface ve 5
ip address 5.5.5.1/30
evpn default
vlan add 5

L3VNI new tenant non VRF default Configuration
========================
#at each end tunnel VNI device (Leaf)
vrf baru
rd 192.168.0.2:101
evpn irb ve 4090
address-family ipv4 unicast
route-target export 101:101 evpn
route-target import 101:101 evpn
address-family ipv6 unicast
route-target export 101:101 evpn
route-target import 101:101 evpn
*rd, rt , vrf name and ve ID can be adjusted within scenario
bridge-domain 4090
router-interface ve 4090
interface Ve 4090
vrf forwarding baru
ipv6 address use-link-local-only
no shutdown
evpn default
bridge-domain add 4090

If some VLAN want to put in to new tenant non VRF default
======================================
#at each end tunnel VNI device (Leaf)
vlan 5
router-interface ve 101
suppress-nd
suppress-arp
interface ve 5
vrf forwarding baru
ip address 5.5.5.1/30
no shutdown









Leave a Reply

Your email address will not be published. Required fields are marked *